21st March 2020

New York, US New York outage

We are investigating the issue.

Update 01:16:

Issue located, bandwidth supplier outage. Awaiting update.

Update 3:45:

Location now back online and fully operational.